0
EMBL Hamburg Biological
Small Angle Scattering
BioSAXS

PRIMUS manual

primus qt

Written by D. Franke.
Post all your questions about PRIMUS to the ATSAS Forum.

© ATSAS Team, 2009

Table of Contents

Manual

Introduction

primus User Interface

Menus

The File-menu: 'File' menu

CaptionDescription
Open Open one or more data files from the hard disk or attached network shares.
Close All Close all data files currently open. To close an individual file, use Close in the context menu of the respective file.
Synchronize Ranges Generally, plot-ranges are adjusted for each opened data file independently. If checked, all ranges are synchronized and modified together.
Toggle All Toggle the plot state of all currently opened data files.
Quit/td> Close the primus main window and quit the application.

The Plot-menu: 'Plot' menu

CaptionDescription
I vs. s (Absolute Scale) Display the currently selected data files in absolute scale.
log(I) vs. s (Absolute Scale) Display the currently selected data files in logarithmic scale (the default).
I*s^2 vs. s (Kratky Plot) Display the currently selected data files as Kratky Plot.
Print Print the current plot area. Allows high-resolution exports of the plot area if printed to PDF.
Export Export the current plot area to a graphics file format, e.g. PNG. The output is a low-resolution image at screen resolution, if high(er)-resolution is required, print to PDF.
Zoom Zoom and Move are mutually exclusive. If Zoom is selected, selecting a region on the plot area will zoom in. One may zoom in multiple times, right-click will zoom out.
Move Zoom and Move are mutually exclusive. If Move is selected, the plot area may be dragged to adjust the field of view. Right clicking has no effect.
Configure Configure the plot area. Specify titles, fonts and colors.

The Tools-menu: 'Tools' menu

CaptionDescription
Radius of Gyration Graphical User Interface to estimate the Radius of Gyration of the first selected data file. Right-click any data file and select Radius of gyration from the Tools menu to use any file.
Porod Volume Not implemented yet.
Distance Distribution Graphical User Interface to GNOM.

The Settings-menu: 'Settings' menu

CaptionDescription
Show 'documents' window Enable or disable the display of the documents window, enabled by default.
Show 'documents' toolbar Enable or disable the display of the documents toolbar, enabled by default.
Show 'plot' toolbar Enable or disable the display of the plot toolbar, enabled by default.
Configure primus Open the primus settings dialog.

The Help-menu: 'Help' menu

CaptionDescription
Help Contents Opens the ATSAS help browser.
About primus Information about primus.
About Qt Information about Qt.

Toolbars

The Documents-toolbar: 'Documents' toolbar

The entries in this toolbar are identical to those described in the File-menu.

This toolbar can be enabled or disabled in the corresponding entry in the Settings-menu.

The Plot-toolbar: 'Plot' toolbar

The entries in this toolbar are identical to those described in the Plot-menu.

This toolbar can be enabled or disabled in the corresponding entry in the Settings-menu.

Dock Windows

Dock windows can be dragged and freely moved.

The Documents-Window: 'Dock Document' widget

This dock window can be enabled or disabled in the corresponding entry in the Settings-menu.

FieldDescription
Filename The basename of the data file openend; the corresponding curve is shown in the plot area if checked.
Range From First point of the data file to plot. Ranges between files are independent, but may be synchronized.
Range To Last point of the data file to plot. Ranges between files are independent, but may be synchronized.
Concentration Concentration as extracted from the data file. May be temporarily changed in the dialog. To change persistently, open the file in an external editor, modify and reload afterwards.
Multiplier Scales the corresponding function by the value specified. Default is 1.0, i.e. no scaling at all.

Right-clicking in the free area of the documents window opens the context menu of the documents-window: Context menu of 'Dock Document' widget The entries in this menu are identical to those described in the File-menu.

Right-clicking a filename opens the file-related context menu: File-related context menu

CaptionDescription
Save As ... Save the multiplied data range to a new file.
Open with external editor Open the associated data file in the specified external editor.
Reload Reload the associated data file, necessary to make changes in the file effective.
Browse Replace the currently opened data file by another at the the position in the document list.
Close 'filename' Close the currently loaded data file and remove the entry in the document list.
Angular Scaling
Tools The entries in the sub-menu are identical to the Tools-menu, but tools will be applied to the currently selected file, not the first selected in the list.

Dialogs

The primus Settings dialog: configuration dialog

FieldDescription
Path to ATSAS binaries
Path to ATSAS help file
External editor Editor to use to open files in.

Operations

Average













Subtract


















Adjust



























Merge








AutoMerge

Examples

Extrapolation to Zero Concentration


  Last modified: April 11, 2013

© BioSAXS group 2013